Upgraded Firefox and cant get your old extentions to work? Heres the fix!

Hey Guys,
I am sure alot of you have upgraded you Firefox browser lately and some of you would have found that your old extensions don’t work anymore. The reason for this is that they are not yet compatible with the new version. All is not lost though, as there is a fix that will allow you to get them working, without downgrading. Heres how:

(this method is depreciated.  Make sure to check the last sentence)
For all of those who just downloaded Firefox 1.5 and can’t get your extensions to work. This is a simple modification of Firefox’s configuration to trick the extensions to work. No need to manually edit the extensions to get them to work. Currently all the extensions I use work except the bookmark sync extension that I so dearly want to.

1. At the location bar, enter: about:config. This will show you a list of Firefox internal preferences.

2. Right-click on the list, select New > String

Enter “app.extensions.version” (without quotes) for the preference name.

3. Then, enter “1.0” (without quotes) as the value for app.extensions.version.

4. Restart Firefox 1.5, then enable those disabled Firefox extensions.

5. Restart Firefox 1.5 again to active the extensions. Done.

Personally I think this is the best solution because you can always go back and delete the string later rather then fiddling with the extensions.

[UPDATE]
If you change 1.0 back to 1.5 Spoofstick [and potentially others] will continue to work and can also look for updates.

[UPDATE 2]
This method is outdated. It is much easier to simply install the Nightly Tester Tools addon.

About the author

Submit a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>